Millones de sitios web en Riesgo, Soporte para PHP 5.6.x Termina en 2 Meses

Las versiones más populares de PHP no están respaldadas por PHP.net y recientemente hemos tenido que añadir PHP 5.5 a la lista de las versiones de PHP sin soporte. Esto significa que cualquier nueva vulnerabilidad de seguridad descubierta en la versión 5.5 y anteriores no será parcheada ni corregida por PHP.net.

En otras palabras, después de diciembre 31, 2018, millones de sitios web dejarán de recibir actualizaciones de seguridad para sus servidores, y por lo tanto el ecosistema PHP estará expuesto multiples riesgos de seguridad. 

Según Scott Arciszewski, Director de Desarrollo de la Iniciativa Empresarial Paragon, es muy probable que “cualquier  defecto de masa explotable en PHP 5.6 afectará también a las nuevas versiones de PHP“.

Debe tenerse en cuenta que PHP 7.2 recibirá un parche desde el equipo de PHP, gratis, de una manera rapida. 

¿Sabías que casi 80% de todos los sitios web se ejecutan en PHP? Más particularmente, “PHP es utilizado por 78.9% de todos los sitios web cuyo lado del servidor lenguaje de programación que sabemos“, según lo revelado por las estadísticas W3Techs. Este hecho por sí solo hace que la seguridad de PHP una cuestión muy importante, y cuando se agrega el hecho de que el apoyo a PHP 5.6.x termina a finales de este año, la materia de seguridad se vuelve crítica.

Uso de versiones PHP

Uso de versiones PHP

Uso de versiones PHP5

Uso de versiones PHP5

PHP.net es el lenguaje de programación más popular. Según W3Techs.com, tiene el 82% del mercado y está creciendo día a día.

Como se muestra en la imagen superior, PHP 5 es utilizado por el 97,8% de todos los sitios web que utilizan PHP y la versión 5.5 es utilizado por el 20% de todos los sitios web que utilizan la versión de PHP 5. Debido a su masividad, PHP es constantemente explotado y utilizado por piratas informáticos, haciendo que sitios web sean vulnertables.

¿Cómo protejo mi sitio?

Por lo general, las versiones no soportadas tienen problemas de seguridad y significa que el usuario o dueño de un sitio web que utiliza PHP tiene que actualizar sus programas o scripts. Pero muy a menudo, los propietarios de sitios web no son capaces de actualizar y modificar los programas para adaptarse a las nuevas versiones con rapidez para garantizar la seguridad de sus sitios.

Pero, siempre hay un “pero”, si estás utilizando nuestro servicio de Alojamiento Web   no tienes porque preocuparte, , tus sitios estarán seguros. Aunque recomendamos actualizar tus scripts para que utilicen la última versión de PHP, tienes más tiempo para hacer la transición.

En hostingDatos y Veflat aplicaremos una actualizacion para cambiar la version PHP a 7.2, mantente al tanto de las redes sociales y de tu panel de control.

jorgeosoriodev
PHP Full Stack Developer.
Sitio web https://veflat.com
Entradas creadas 5

Entradas relacionadas

Comienza escribiendo tu búsqueda y pulsa enter para buscar. Presiona ESC para cancelar.

Volver arriba
Sígueme en Feedly